Настройка IPTV на openwrt

Настройка компьютеров, модемов. и остального оборудования

Модератор: Lucky SB

Настройка IPTV на openwrt

Сообщение Steelfish » 12 май 2015 14:29

Не получается настроить IPTV на роутере tp link mr3420 OpenWrt Barrier Breaker 14.07
Делал по этому мануалу http://wiki.openwrt.org/ru/doc/howto/udp_multicast, но видимо где то накосячил =(
конфиги:
igmpproxy
Код: Выделить всё
config igmpproxy
   option quickleave 1

config phyint
   option network wan
   option direction upstream
   altnet 10.0.0.0/8

config phyint
   option network lan
   option direction downstream

config phyint
   option network loopback
   option direction disabled


firewall
Код: Выделить всё
config defaults
   option syn_flood '1'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'ACCEPT'

config zone
   option name 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'ACCEPT'
   option network 'lan'

config zone
   option name 'wan'
   option output 'ACCEPT'
   option masq '1'
   option mtu_fix '1'
   option network 'wan wan6 Freedom_l2tp dhcp'
   option input 'ACCEPT'
   option forward 'ACCEPT'

config forwarding
   option src 'lan'
   option dest 'wan'

config rule
   option name 'Allow-DHCP-Renew'
   option src 'wan'
   option proto 'udp'
   option dest_port '68'
   option target 'ACCEPT'
   option family 'ipv4'

config rule
   option name 'Allow-Ping'
   option src 'wan'
   option proto 'icmp'
   option icmp_type 'echo-request'
   option family 'ipv4'
   option target 'ACCEPT'

config rule
   option name 'Allow-DHCPv6'
   option src 'wan'
   option proto 'udp'
   option src_ip 'fe80::/10'
   option src_port '547'
   option dest_ip 'fe80::/10'
   option dest_port '546'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Input'
   option src 'wan'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   list icmp_type 'router-solicitation'
   list icmp_type 'neighbour-solicitation'
   list icmp_type 'router-advertisement'
   list icmp_type 'neighbour-advertisement'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Forward'
   option src 'wan'
   option dest '*'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-IGMP'
   option src 'wan'
   option proto 'igmp'
   option target 'ACCEPT'

config rule
   option name 'Allow-IPTV-IGMPPROXY'
   option src 'wan'
   option proto 'udp'
   option dest 'lan'
   option dest_ip '10.0.0.0/8'
   option target 'ACCEPT'


config include
   option path '/etc/firewall.user
'
И два статически маршрута в network
Код: Выделить всё
config route
   option target '10.0.0.0'
   option netmask '255.255.255.255'
   option gateway '10.16.68.1'
   option interface 'lan'

config route
   option target '192.168.149.128'
   option netmask '255.255.255.192'
   option gateway '10.16.68.1'
   option interface 'lan'
Аватара пользователя
Steelfish

 
Сообщения: 1
Зарегистрирован:
12 май 2015 14:14

Вернуться в Проблемы в настройке оборудования

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3